Monday, May 15, 2006

 
OpenBSD 3.9 and RoR

# export PKG_PATH=ftp://rt.fm/pub/OpenBSD/3.9/packages/i386
# pkg_add ruby-iconv
# pkg_add mod_fastcgi
# pkg_add fcgi
# mod_fastcgi-enable



download rubygems
# lynx rubygems.org
# tar zxf ruby*
# ruby setup.rb

install rails, fcgi, mysql
# gem install rails
# gem install fcgi -- --with-fcgi-lib=/usr/local/lib --with-fcgi-include=/usr/local/include
# gem install mysql -- --with-mysql-lib=/usr/local/lib --with-mysql-include=/usr/local/include




Comments:
For PostgreSQL do the following:
$ sudo gem install postgres
(you'll get an error like this: Could not find PostgreSQL libraries: Makefile not created)
now cd into "/usr/local/lib/ruby/gems/1.8/gems/postgres-0.7.1"
and fire this three commands up:
$ sudo ruby extconf.rb --with-pgsql-include-dir=/usr/local/include/postgresql --with-pgsql-lib-dir=/usr/local/lib/postgresql
$ sudo make
$ sudo make install
Thats all :)
 
Post a Comment



<< Home

This page is powered by Blogger. Isn't yours?